Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000449FlexRAID RAID-F[All Projects] Generalpublic2017-02-10 21:102017-11-24 05:13
Reporterwebs0r 
Assigned ToBrahim 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformWindowsOSServerOS Version2008 r2
Summary0000449: View not reconnecting shares after reboot
DescriptionHi Brahim this is happening 100% of the time for me.

It only started happening AFTER I reset my FlexRAID config.

I think that is related; i.e. deleting the view config and creating new view config.

Using the server backup shares option in the view config does not do anything or log any lines in the log.
Steps To ReproduceThis is what I think - I can't test this again :)

0. Have an existing view config with shares set up and remembering correctly.
1. I deleted my RAID-F RAID pools and I deleted the view config.
2. Then I re-made the RAID pools, recreated the parity.
3. Then I re-created the view config.
4. Restart
5. No shares
6. Create a share
7. Restart
8. See logs below
Additional InformationShowing log from step 4 onwards -
see line [2017-02-11 08:01:06,811]
During shutdown, I wonder if this is where it is trying to save the share info and failing?

[2017-02-11 07:51:13,552] INFO : Setting core service port to 9595
[2017-02-11 07:51:13,552] INFO : Setting Http port to 8080
[2017-02-11 07:51:13,552] INFO : Https port not set. Https requests will not be serviced...
[2017-02-11 07:51:13,567] INFO : Starting FlexRAID...
[2017-02-11 07:51:13,567] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.09.14]
[2017-02-11 07:51:13,567] INFO : Started: 11 February 2017 7:51:13 AM
[2017-02-11 07:51:26,390] INFO : Initiating FlexRAID Storage Pool...
[2017-02-11 07:51:26,422] INFO : Host OS = Microsoft Windows [Version 6.1.7601]
[2017-02-11 07:51:26,422] INFO : Building View Registry...
[2017-02-11 07:51:26,422] INFO : Building Auto View Registry...
[2017-02-11 07:51:26,437] INFO : Loading View options...
[2017-02-11 07:51:27,264] INFO : Using Auto-View definition...
[2017-02-11 07:51:27,264] INFO : Building View Handler...
[2017-02-11 07:51:27,326] INFO : Mounting Storage Pool drive...
[2017-02-11 08:01:00,705] INFO : Service stopping...
[2017-02-11 08:01:00,705] INFO : Stopping views...
[2017-02-11 08:01:00,705] INFO : Unmounting View...
[2017-02-11 08:01:05,729] INFO : Unmounting View complete...
[2017-02-11 08:01:05,729] INFO : Stopping scheduler...
[2017-02-11 08:01:05,729] INFO : Stopping web server...
[2017-02-11 08:01:05,780] INFO : Stopping socket server...
[2017-02-11 08:01:05,782] INFO : Shutting down at: 11/02/17 8:01 AM
[2017-02-11 08:01:05,782] INFO : Closing all client connections...
[2017-02-11 08:01:05,782] INFO : Exiting all processes...
[2017-02-11 08:01:06,811] ERROR: Connection refused: connect
java.net.ConnectException: Connection refused: connect
    at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at com.tchegbe.lib.b.a.b.a(Unknown Source)
    at com.tchegbe.lib.b.a.e.a(Unknown Source)
    at com.tchegbe.lib.b.a.g.a(Unknown Source)
    at com.tchegbe.lib.common.i.d.b(Unknown Source)
    at com.tchegbe.lib.common.i.a.run(Unknown Source)
[2017-02-11 08:01:07,825] ERROR: Connection refused: connect
java.net.ConnectException: Connection refused: connect
    at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at com.tchegbe.lib.b.a.b.a(Unknown Source)
    at com.tchegbe.lib.b.a.e.a(Unknown Source)
    at com.tchegbe.lib.b.a.g.a(Unknown Source)
    at com.tchegbe.lib.common.i.d.a(Unknown Source)
    at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
    at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
    at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
    at com.tchegbe.lib.io.a.h.run(Unknown Source)
[2017-02-11 08:02:49,442] INFO : Setting core service port to 9595
[2017-02-11 08:02:49,442] INFO : Setting Http port to 8080
[2017-02-11 08:02:49,442] INFO : Https port not set. Https requests will not be serviced...
[2017-02-11 08:02:49,458] INFO : Starting FlexRAID...
[2017-02-11 08:02:49,458] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.09.14]
[2017-02-11 08:02:49,458] INFO : Started: 11 February 2017 8:02:49 AM
[2017-02-11 08:03:02,281] INFO : Initiating FlexRAID Storage Pool...
[2017-02-11 08:03:02,312] INFO : Host OS = Microsoft Windows [Version 6.1.7601]
[2017-02-11 08:03:02,312] INFO : Building View Registry...
[2017-02-11 08:03:02,312] INFO : Building Auto View Registry...
[2017-02-11 08:03:02,328] INFO : Loading View options...
[2017-02-11 08:03:03,155] INFO : Using Auto-View definition...
[2017-02-11 08:03:03,155] INFO : Building View Handler...
[2017-02-11 08:03:03,217] INFO : Mounting Storage Pool drive...
TagsNo tags attached.
RAID-F Version 2.1
Attached Files

- Relationships

-  Notes
(0001732)
Brahim (manager)
2017-02-10 22:16

This is not a bug. Configured shares are discarded once the configuration is deleted.
(0001733)
webs0r (reporter)
2017-02-10 22:24

No Brahim please take your time to read my details more carefully.

User deletes config.
User creates a new configuration.
Then creates shares.
Now shares are never remembered, ever!

This surely is not the intended behaviour of the product.
(0001750)
Brahim (manager)
2017-11-24 05:13

Hi, please verify that the issue still persist in the latest build.
Also, if the shares are not remembered naturally, please try the "Backup Storage Pool Shares" option after the shares have been created.

- Issue History
Date Modified Username Field Change
2017-02-10 21:10 webs0r New Issue
2017-02-10 22:16 Brahim Note Added: 0001732
2017-02-10 22:16 Brahim Status new => closed
2017-02-10 22:16 Brahim Assigned To => Brahim
2017-02-10 22:16 Brahim Resolution open => no change required
2017-02-10 22:24 webs0r Note Added: 0001733
2017-02-10 22:24 webs0r Status closed => feedback
2017-02-10 22:24 webs0r Resolution no change required => reopened
2017-11-24 05:13 Brahim Note Added: 0001750


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker